COMMUNITY

Constant Framerate of 10fps or Less
2 years ago  ::  May 25 2012 - 7:34PM
Posts: 4 Joined: May 25, 2012

I just installed Saints Row: The Third on my fairly new PC, and no matter what graphics settings I use, and regardless of whether I run the game in DirectX 10/11 mode or DirectX 9 mode, my frame rate is never above 10fps. I have just updated my graphics drivers, sound drivers, and verified latest DirectX End User Runtime from Microsoft is installed, and has Steam verify game files. I even tried unplugging my Logitech USB headset, just in case it was causing a problem. I also disabled my anti-virus software, and then manually stopped the services.


Here's a link to my DxDiag.txt:


Here are my relevant systems specs:



  • AMD FX-8120 Processor (overclocked by 10%)

  • ASUS M5A88-M Motherboard

  • 16GB of G.SKILL DDR3 RAM

  • ASUS ENGTX560 DCII (stock overclocked) Graphics Card with 1GB 256-bit GDDR5

  • SilverStone ST75F-G 750W PSU

  • ASUS VE247H 23.6-Inch 1920x1080 LED Monitor


I can run it on the lowest resolution with the lowest graphics settings, and it will run at 10fps. I can run it at 1920x1080, and it will run at 10fps.


Some assistance would be appreciated.

Quick Reply
Cancel
2 years ago  ::  May 29 2012 - 12:04PM
Posts: 4 Joined: May 25, 2012

I just noticed Steam say it had finished downloading Saints Row: The Third, and I just wanted to mention that if there was an update it did not make any difference with this issue. Game performance is still terrible and unplayable.

Quick Reply
Cancel
2 years ago  ::  May 30 2012 - 10:06AM
Posts: 4 Joined: May 27, 2012


  • AMD FX-8120 Processor (overclocked by 10%)

  • ASUS M5A88-M Motherboard


Update your motherboard bios :)

Quick Reply
Cancel
2 years ago  ::  May 30 2012 - 9:33PM
Posts: 4 Joined: May 25, 2012

Well, I just flashed my BIOS. Don't ask me why I did it now when I didn't care enough to do it a couple of months ago when I built this new system, but I saw your message and I just said "sure, why not".


 Anyway, it solved my problem. No more performance issues. Thanks for the kick in the head. Wink 

Quick Reply
Cancel
2 years ago  ::  Jun 1 2012 - 11:06AM
Posts: 4 Joined: May 25, 2012

Just an interesting note: After installing that BIOS update, now when I launch Saints Row: The Third, my second monitor goes completely black, whereas it didn't do that before. I have a feeling that it has something to do with the fact that I am running the DX10/11 version, and I have to running with my 'global' NVIDIA driver settings which include "Single Display Performance Mode". I had tried "Multiple Display Performance Mode" and whatever they call their compatibility mode for the DX9 binary when I was having all of the trouble with it.

Quick Reply
Cancel
2 years ago  ::  Jun 2 2012 - 5:50PM
Posts: 4 Joined: May 27, 2012

as far as the multiple display issue, is it multiple cards, or multiple outputs on a single card? I am currently on my new radeon cards so i cant double check the nvidia global settings necessary... im sure its probably just an issue with the output/cloning settings in the nvidia control center.

Quick Reply
Cancel