Storage Device does not have enough space
3 years ago  ::  Nov 19 2011 - 10:41PM

I am having trouble saving my game.  I can play it fine, but when i start a new game in comes up with a message saying "the storage device you have selected does not have enough space to create a new save".  I dont know what i should do for this.  Can someone thell me how to fix this so i can same my game

Quick Reply
3 years ago  ::  Nov 20 2011 - 12:21AM
Posts: 348 Joined: Oct 24, 2011

According to other complaints i've seen, the game cannot reliably save your game locally, and requires the Steam Cloud feature to be used (at least for some people). So, make sure that's enabled. Aside from that, i don't know what would be causing this.

Quick Reply
3 years ago  ::  Nov 22 2011 - 6:11PM
Posts: 1 Joined: Nov 19, 2011

Same proble here ....

Quick Reply
3 years ago  ::  Dec 5 2011 - 11:00AM
Posts: 1 Joined: Dec 4, 2011

I finally got it to work.


I did a lot of looking around to solve this problem without luck and tried a lot of different things. Even a cracked executable. Unfortunately it solved the problem but I simply refused to play with this executable since I paid for the game and wanted it to run properly with updates from steam. It was, however, interesting that it worked.

Someone said that if you linked your account to the one on Saints Row 3, it worked. I tried that, and it seemed to work!

And tonight it didn't work!!! My save games were gone, although they still were physically on my harddisk.

So this is what I did to make it work again:

- Downloaded the SR3 Demo (Character Creator) and made a character which I uploaded to the Saints Row 3 site (Had to restart Steam first as the demo thought I was online)
- Started SR3, ignoring the message that my storage device had no space
- When I was able to customize my character, I connected to the SR3 site and downloaded my character, thus linking my Steam and SR3 Site Accounts
- Played the game and verified the save game worked

It worked perfectly until I wanted to play today.

Must frustration!

Restarting Steam worked and my save games were intact. I think there is a bug in SR3 or Steam (or a combination) and loses connection if your computer hibernates (or maybe when shutting down and restarting too).

So if you still have the issue, try restarting steam first. Then perhaps try linking your steam account to the SR3 Site Account and see if that helps.

Hopefully it will help you as well since restarting the game every time is getting rather boring :D 

Quick Reply
3 years ago  ::  Dec 5 2011 - 11:48AM
Posts: 6526 Joined: Sep 16, 2011

As Corrodias stated above, this issue mainly has to do with Cloud Saving and the Cloud feature on Steam. Before you start to play your game, ensure that the little cloud icon is activated in your Library next to SR:TT. If it's not, log out and log back into Steam, and wait for it to appear. This should entirely correct the issue.

Community Manager - Volition, Inc.
Follow me on Twitter - @One_Letter (
Quick Reply
3 years ago  ::  Dec 17 2011 - 1:03PM
Posts: 1 Joined: Dec 17, 2011

is there another way without connecting to the internet 

Quick Reply
2 years ago  ::  Mar 25 2012 - 3:57AM
Posts: 1 Joined: Mar 25, 2012

i have the cd of this game and i installed it but the problem i cant save i tried many thingsss but nothing works wht should i do the easiest way plzzz tell me

Quick Reply
2 years ago  ::  May 22 2012 - 11:07PM
Posts: 1 Joined: May 22, 2012



Quick Reply
2 years ago  ::  Jul 9 2012 - 7:52PM
Posts: 1 Joined: Jul 9, 2012

im bored to play this game...i cant save ..did not have space...just one way to do it...dont play the other cant fix this thing

Quick Reply
2 years ago  ::  Nov 28 2012 - 5:13PM
Posts: 1 Joined: Nov 25, 2012

Made it work by disabling Steam Cloud for the game!

This is how you do VERY EASY:

1. Go to your Steam library and right click at your Saint Row.

2. Go to Properties and then go to the Updates tab.

3. Unmark/disable the box that says "Turn on Steam Cloud synchronization for Saint Row: The Third".

You are done!

Have fun! 

Quick Reply