COMMUNITY

Bodies disappear on Australian xbox playing NTSC version of Saints Row
4 years ago  ::  Jan 26 2010 - 2:09PM
hp32s
Posts: 5

Why do the bodies disappear straight away (like in the demo) when you kill someone?

I have the USA NTSC Saints Row (it's region free) and play it on my Australian Xbox 360. I have played this disc on a friends imported US xbox 360 and the bodies don't disappear like they do on my Australian 360. I have also played the Australian PAL Saints Row on my xbox and again the bodies don't disappear. So there seems to be a bug with the NTSC version of the game as it won't play properly on my xbox 360.

So is this a bug you know about and will this be fixed in the upcomming patch? Please help.
Thanks.

8 years ago  ::  Sep 8 2006 - 2:17AM
HarryWho
Posts: 65

it aint no bug. when alot is going on at once, boddies will still dissapear...fact, get over it!

8 years ago  ::  Sep 8 2006 - 2:58AM
hp32s
Posts: 5

No you get over it. It happens when nothing is going on at all (like when there are no cars around and two or three people max). You shoot somebody in the head they fall to the ground and they disappear straight away in under one second. How come it dosn't do it on a USA xbox 360 machine using the same exact disc. Do you have an Australian xbox 360 and the USA version of Saints Row?

8 years ago  ::  Sep 8 2006 - 7:41AM
HarryWho
Posts: 65

i have a pal xbox , and i bought the game in queensland australia. and its fine. the bodies stay to kick and stuff, but somtimes dissapear, it seems sweet to me. dont worry about it, there not going to do anything more than theyeve allready done... and what they done is just fine.

8 years ago  ::  Sep 8 2006 - 8:47AM
vScourge
Posts: 134

What do you have your locale set to on your 360's settings?

8 years ago  ::  Sep 10 2006 - 9:05PM
hp32s
Posts: 5

Quote by HarryWho
i have a pal xbox , and i bought the game in queensland australia. and its fine. the bodies stay to kick and stuff, but somtimes dissapear, it seems sweet to me. dont worry about it, there not going to do anything more than theyeve allready done... and what they done is just fine.

Sounds like you have the PAL version of the game which has no problem. But with mine the bodies dissapear straight away and you can NEVER kick them around ect.

Quote by V-Scourge
What do you have your locale set to on your 360's settings?

It is set to Australia.

Just noticed yesterday when you load the game that it shows the Australian rating classification on the title screen instead of the American one which is printed on the cover. Therfore the game must be detecting what console it is being played on and setting it for the correct country. Which explains why the game works differently on a USA 360 and a AUS 360. But unfortunately it dosn't help explain why the bodies dissapear on my Aus 360 and not on a USA 360. So I still think it's a bug or mistake.

8 years ago  ::  Sep 11 2006 - 12:58AM
iceman654
Posts: 333

I think it's because Volition are using region based censoring. I've been saying this for a while now & all of the evidence points to it. The same thing happened with the demo.

8 years ago  ::  Sep 11 2006 - 7:37AM
vScourge
Posts: 134

I don't know if censoring is the right word. In any case, we have conformed to specific requirements for the ratings boards in each region in order to give SR a "mature" (or equivalent) rating everywhere.

In Australia, I believe that required the change to how long dead bodies stay around.

8 years ago  ::  Sep 11 2006 - 9:56AM
iceman654
Posts: 333

Wrong, even members of your own team have confirmed that the version released in Australia is the same version released in US/UK. Besides, I can tell you that the bodies don't dissappear :)

This is fairly old news now.

8 years ago  ::  Sep 11 2006 - 1:25PM
vScourge
Posts: 134

I believe it's the same disc, but there is region-specific differences in how the content is handled in some territories.

If I remember correctly, there was a bug in the Aus/NZ region that caused bodies to disappear, even though it wasn't required for ratings purposes, but that bug was fixed with a zero-day update. IMacMan or another mod can probably confirm that, since I'm not positive.

It might be that the original author doesn't have a Live connection or otherwise hasn't received that zero-day update.